Installing Swift

macOS

In order to use the Swift exercises, install Xcode version 8.0 or greater. On the first launch of Xcode, install the command line tools when prompted.

The current release version is available at the Mac App Store.

Additional versions of Xcode (including the most recent beta) are available at Apple's developer center.

All exercises have been tested with Xcode 8.0 using Swift 3.

Linux

The latest release is available on Swift.org.

Swift.org installation instructions.


Help us explain this better! File a GitHub issue at https://github.com/exercism/swift/issues if you have suggestions, or submit a patch with improvements to the https://github.com/exercism/swift/blob/master/docs/INSTALLATION.md file.